Incident Re-start: Friday 22:00 Paris time (API changes) Final Resolution: Sunday, June 1st at 9:00 AM Paris time Impact: Service Restored Affected Services: Photo posts on X (Twitter)
Issue Description: On Friday at 22:00 Paris time, X (Twitter) made unnoticed breaking changes to their media upload API without prior notice. The old media upload method has been removed, requiring immediate migration to new separate endpoints (/initialize, /append, /finalize). Resolution: After investigation this weekend, we successfully implemented the new API method. Photo posts on X are now working normally.
User Impact: ✅ Photo posts on X: Now working normally ✅ Link posts on X: Working normally ✅ Text-only posts on X: Working normally ✅ Other social networks: Not affected (Facebook, Instagram, LinkedIn, etc.) ✅ Analytics and statistics: Not affected
Current Status ✅ Photo posts on X are fully functional - We have successfully migrated to X's new API endpoints and all features are working normally. We continue to monitor the service stability and will provide updates if any issues arise. Thank you for your patience during this incident caused by X's undocumented API changes.
Posted Jun 01, 2025 - 07:49 UTC
Monitoring
✅ Photo posts on X are currently working
The X media upload API appears to be functioning again and photo posts are now working. However, since X's status page may not reflect the complete resolution, we are closely monitoring the situation.
We will continue to monitor for any recurrence and will update this status once we're confident the issue is fully resolved.
Posted May 30, 2025 - 12:00 UTC
Identified
X has acknowledged the media upload API issue and is working on a resolution.
We will continue monitoring and will update you once the service is restored.
Posted May 29, 2025 - 04:37 UTC
Investigating
We are currently experiencing issues with X's media upload API. The endpoint https://api.x.com/2/media/upload is returning a 404 error, preventing the publication of photo posts on X. User Impact
❌ Photo posts on X: Not working ✅ Video posts on X: Working normally ✅ Link posts on X: Working normally ✅ Text-only posts on X: Working normally ✅ Other social networks: Not affected (Facebook, Instagram, LinkedIn, etc.)
Current Actions
Technical team investigation in progress Monitoring X API status Contacting X support to report the issue
Temporary Workarounds While we work on a resolution:
You can publish text-only content and link posts on X Photo posts work normally on other platforms Photos can be manually added via X interface after text publication
Updates We will keep you informed of the situation's progress. This page will be updated as soon as we have more information.